Configurar un router con openwrt desde ssh para que funcione como un repetidor de señal

La información que aquí explico la he cogido de dos blogs y la he fusionado.

http://foro.seguridadwireless.net/openwrt/%28tutorial%29-modo-clienterepetidor-openwrt/
http://tombatossals.github.io/openwrt-repetidor-wireless/
http://wiki.openwrt.org/doc/uci/wireless

En mi caso con un router tp-link tl-rm3420 no he podido instalar LUCI y he tenido que configurarlo desde el ssh. Para todo ello he hecho lo siguiente.

1. Configurar el router como un cliente del router principal:

Borramos configuración. Esto se hace borrando el sistema filesystem jffs2 del directorio /overlay, que es el rootfs_data:

mtd -r erase rootfs_data

Borramos interficies wan

uci del network.wan

Cambiamos la subred de la interfaz lan del router a una distinta del router principal

uci set network.lan.ipaddr=192.168.2.1
uci set network.lan.netmask=255.255.255.0
uci set network.lan.dns=8.8.8.8
uci set network.lan.nat=1
uci set network.lan.accept_ra=1

Permitimos conexiones dinámicas DHCP

uci set dhcp.lan.dynamicdhcp=1

Creamos interfaz para el WLAN

uci set network.wan=interface
uci set network.wan.proto=dhcp

mostramos la configuración wireless

uci show wireless

Habilitamos la interfaz wireless

uci set wireless.radio0.disabled=0
uci commit wireless

Aquí deberemos volver a logearnos pues se habrá cambiado la IP del router
y seguimos ejecutando habilitando el wifi

wifi

Y cambiamos su configuración (del wifi aquí va la configuración para conectarse via wifi el router principal):

uci set wireless.radio0.channel=1
uci set wireless.@wifi-iface[0].ssid=WLAN
uci set wireless.@wifi-iface[0].mode=sta
uci set wireless.@wifi-iface[0].network=wan
uci set wireless.@wifi-iface[0].encryption=psk2
uci set wireless.@wifi-iface[0].key=contraseña
uci set firewall.@zone[1].input=ACCEPT
uci set firewall.@zone[1].masq=1
uci commit
reboot

Hasta aquí seremos capaces de conectarnos con el router secundario al principal por wifi y tener internet en sus puertos ethernet. Nos queda

2. habilitar la repetción por wifi.

opkg update
opkg install relayd
/etc/init.d/relayd enable
Editar el archivo /etc/config/wireless y añadir al final estas lineas:
config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'nuevo-router-casero'
        option encryption 'psk2'
        option key 'micontraseñamuysecreta'
        option network 'lan'
Editar el archivo /etc/config/network y añadir al final estas lineas
config interface 'stabridge'
        option 'proto' 'relay'
        option 'network' 'lan wwan'
Ya solo queda reiniciar el router
Comments Are Closed